ヘルプ > EC > 出品 > レシートプリンターのテスト印刷時に「値をNullにすることはできません。パラメーター名: device」と表示される時の対処法

レシートプリンターのテスト印刷時に「値をNullにすることはできません。パラメーター名: device」と表示される時の対処法

  • 公開日:2025年05月26日
  • 更新日:2025年06月02日

本ガイドでは、レシートプリンターのテスト印刷時に「値をNullにすることはできません。【パラメーター名: device】」と表示されれる時の対応方法について解説します。

エラー
値をNullにすることはできません。パラメーター名: device

原因

レシートプリンターを使用するにあたり、必要なドライバーがPCにインストールされていない、もしくはドライバーインストール後にOPOS設定が行われていない。

対応方法

Step①:必要なドライバーがインストールされているかを確認

以下の手順に沿って操作ください。

①【Windows】の【スタート】ボタンクリック

②【設定】をクリック

③【アプリ】より【インストールされているアプリ】をクリック

④以下のアプリを1点ずつ検索確認し、ドライバーがインストールされているかを確認する。

  • EPSON OPOS ADK for .NET
  • EPSON APD5 Plugin for TM-m30

Step②:インストールされていないドライバーのダウンロード

以下を参照のうえ、インストールされていないドライバーのインストールをおこなってください。

「EPSON OPOS ADK for .NET」がインストールされていない場合

以下を参照のうえ、ドライバーのインストールを行ってください。

No ドライバー名                    ダウンロード先リンク ダウンロードの詳細
1 『OPOS』
OPOSN1.14.37.zip
※ファイル名OPOSN『〇〇』のバージョンは変わる可能性あり

https://www.epson.jp/dl_soft/readme/42644.htm

『OPOSN1.14.37.zip』ファイルの【使用許諾に同意してダウンロード】をクリックしてダウンロード

ダウンロード後に「ドライバーのインストール」を行います。
手順などがご不明の際は、以下ヘルプガイドをご参照ください。

▼ドライバーのインストール手順
レシートプリンター・カスタマーディスプレイ・キャッシュドロアーの設定>2圧縮ダウンロードファイルの展開

OPOSの設定をされていない場合

ドライバー「EPSON OPOS ADK for .NET」のインストール後に「OPOS設定」を行うことで、レシートプリンターが使用できるようになります。
以下ヘルプガイドを参照のうえご設定ください。

▼OPOS設定手順
レシートプリンター・カスタマーディスプレイ・キャッシュドロアーの設定>Step5:【必須】OPOS設定

「EPSON APD5 Plugin for TM-m30」がインストールされていない場合

以下を参照のうえ、ドライバーのインストールを行ってください。

No ドライバー名                    ダウンロード先リンク ダウンロードの詳細
1 『APD』
APD_513_m30.zip
※ファイル名APD_『〇〇』_30のバージョンは変わる可能性あり

https://partner.epson.jp/support/details/contents022/

『EPSON Advanced Printer Driver』の「Ver.5シリーズ」にある【Tm-m30用プリンタードライバー】をクリックし、ファイルの【使用許諾に同意してダウンロード】をクリックしてダウンロード

ダウンロード後にドライバーのインストールを行います。
手順などがご不明の際は、以下ヘルプガイドをご参照ください。

レシートプリンター・カスタマーディスプレイ・キャッシュドロアーの設定

関連ガイド

関連する記事はこちらです。

No 事象 ヘルプガイド名称 ヘルプガイドURL
1 他機器の設定について 周辺機器セットアップマニュアル 詳しく見る
2 エラー レシートプリンター印刷時に表示されるエラー「The port name is illegal or couldn`t be connected to the device」の対応方法 詳しく見る
3 エラー レシートプリンター印刷時に「オブジェクト参照がオブジェクトインスタンスに設定されていません」と表示されます。 詳しく見る
4 Bluetooth接続の切断エラー Bluetooth対応のレシートプリンターで接続が切れたときの対応方法 詳しく見る
5 エラー キャッシュドロアーのエラー「Could not complete processing within the specified period」と表示される場合の対応方法 詳しく見る
6 エラー 「SetupPOSの処理に失敗しました。変更した内容は保存されません。」と表示されます。 詳しく見る

ご不明点等ございましたら、ヘルプチャットよりお問合せください。

この記事は役に立ちましたか?

ご意見ありがとうございます!